为Debian 10升级Linux Kernel 5.x

目前 Debian 10 自带的内核版本为 4.19,可能由于种种原因...比如不升级手痒,十分希望体验一下新版内核,这篇文章可以指导你如何正确的查询并安装新版内核。
以下方法同时也适用于未来以及先前的 Debian 版本,步骤一致,唯一的区别是将文中的 buster-backports 中的代号更换为你正在使用的系统的代号。

开始

首先来到 Debian Backports 网站查询当前版本是否已经提供 Backports 支持,如果是刚刚发布的版本这里可能没有哦...
也可以访问 Debian Package List 选择 buster-backports 查看可用的软件包列表。

如果要升级内核,可以在 Debian Package List 页面找到 Kernel 分类并进入对应的页面,并使用浏览器搜索 linux-image 来查看可用的内核版本。
但是要注意,linux-image-5.2.0-0.bpo.2-amd64 这种并不是我们想要安装的软件包,如果安装了这种特定版本的软件包会导致未来 Backports 中有新版本发布时系统仍然停留在已安装的特定版本内核,不会自动更新。

那么如何找到适合自己的设备呢?以下提供一些例子:

  • 64位普通设备,如你的笔记本或工作站: linux-image-amd64
  • 64位基于虚拟化的设备,如 AWS、Azure、普通VPS: linux-image-cloud-amd64
  • 树莓派: linux-image-rpi

安装与卸载

不过仍然有一点要注意,直接使用 apt install 上面提到的软件包名并不能直接安装 Backports 内核,因为同样的软件包名也存在于我们当前运行的版本的软件源中,且不能被移除 --- 不然你就没有办法安装大部分软件了

找到适合自己设备的包名并且确定版本是自己需要的版本后,可以执行以下命令进行安装:

sudo apt -t buster-backports linux-image-cloud-amd64 linux-headers-cloud-amd64

注意:如果你使用的不是 buster,而是更早的 stretch 或是未来的版本,请替换 buster 为你的版本代号。当然,也不要忘了替换包名...

安装成功后重启即默认使用最新版本内核,如有疑问可以运行 uname -r 再次确认正在运行的系统内核版本。

注意: 如果安装了新的内核导致设备无法启动,在重新启动时的 GRUB 菜单中选择旧版内核启动并执行 sudo apt -t buster-backports purge linux-image-cloud-amd64 linux-headers-cloud-amd64即可卸载 Backports 内核。

发表评论

电子邮件地址不会被公开。 必填项已用*标注